Server Updates
Incident Report for SchoolData.net
Resolved
All applications are now available.
Posted Mar 16, 2018 - 22:14 PDT
Identified
We are currently performing server maintenance. Applications are unavailable at this time.
Posted Mar 16, 2018 - 21:45 PDT