Degraded Performance
Incident Report for SchoolData.net
Resolved
Server load has returned to normal and Homeroom functionality has been restored. All applications and school districts are operational.
Posted Oct 30, 2017 - 14:41 PDT
Monitoring
We have identified the cause of the issue to be rampant security checks for a Homeroom widget. We are pushing out a fix to address the core issue. Unfortunately, Bethel School District had to be restarted due to the number of pending and hung requests. Other districts will see immediate performance increases and Bethel will have restored services momentarily. We are monitoring server health while the fix is in place to determine if the issue is resolved.
Posted Oct 30, 2017 - 13:55 PDT
Investigating
We are investigating degraded performance for some school districts. In particular, Bethel School District is experiencing increased load times and login errors in Homeroom.
Posted Oct 30, 2017 - 13:33 PDT