SchoolData.net Application Release
Scheduled for Dec 3, 16:00 - 17:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 03, 2021 - 15:58 PST
Scheduled
We will be updating Evaluations and Intervention Plans on Friday, December 3rd at 4PM PST. The following applications will be unavailable at this time:

* Evaluations
* Intervention Plans

The update process should take roughly 1 hour. If you have any questions or need any help at this time, please contact your customer support representative or call us at 509-688-9536.
Posted Nov 19, 2021 - 16:51 PST
This scheduled maintenance affects: Human Resources (Evaluations) and Student Plans (Intervention Plans).